psnGallery2 v1.2.2 is available to download

I fixed few issues, I followed the advices of several of you and specially those from Tarique Sani (Lead Dev Coppermine).

Just click the download link here or on the download menu.

As usual, if you have issue… Leave a comment !

26 thoughts on “psnGallery2 v1.2.2 is available to download”

  1. Yeah i’m using 1.3.2. I’ve set up (i think) as it says in the install instructions, but when i look at the psnGallery page on wordpress admin i get exactly the same output as ahreno, with php reporting the errors on lines 162 & 171.

  2. Hi, i’ve got the same problem as ahreno – exactly the same output actually. Can anyone tell me what the solution is?


  3. the only thing I can imagine is that your table “psnGallery” (within the database of wordpress) is not valid. Can you send me a dump (export) of that table ?

  4. Hey, i was in contact with you earlier aobut a bridge for coppermine / wp… I am trying to get the Alpha running on http://www.kcbme.com/wordpress and it seems to be up and running, i have everything set correctly but when i go into the admin part i get this error: any idea?

    psnGallery2 configuration

    Warning: Invalid argument supplied for foreach() in /home/kcbme/public_html/wordpress/wp-admin/psnCPGAdmin.php on line 162

    Warning: Invalid argument supplied for foreach() in /home/kcbme/public_html/wordpress/wp-admin/psnCPGAdmin.php on line 171
    Parameters coming from Coppermine
    Variable Value
    Your database server
    Your mysql username
    ************ Your mysql password
    Your mysql database name
    Table prefix
    False debug flag
    Maximum pictures displayed at a time
    False EXIF Support ?
    Prefix from post tags

  5. Well, why not… The next release is delayed due to ….euh…. a lot of “DIY” work at home ๐Ÿ˜‰ The release 1.3.0 alpha is ready (that’s the one which s running on this site).

  6. Happy to read that !

    But anyway, I will fix the issue :

    In case that the tag is used with only one parameter (no separator), the argument process is not correctly working.

  7. can you try the following tag : <cpg_album>2|3|1</cpg_album> ? To see the result (may be an issue if no seperator found….As the code is based on ‘|’ as separator….

  8. It looks like In my comment that the tag I had in my post was stripped out, it was
    (cpg_album)2(/cpg_album) But with the round brackets replaced with angle brackets

  9. According the sql, it seems that there is no “albumid” defined (aid=)… That’s the cause of the issue.

    The only thing I can imagine is a typo…may be in the psngallery table.
    Can you provide me the content of your psngallery table ?

  10. Hi,
    I have just installed psnGallery, and everything seems to be fine, except it cannot see any of my albums. On the Admin page, the Albums Viewer has no albums in it, but the Picture Viewer has pictures there.

    Also if I put in a post 2 I get this output

    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ” at line 1]
    SELECT COUNT(*) as nbrows from coppermine.cpg130_pictures WHERE approved = ‘YES’ and aid=
    Nothing to display

    Do you know what the problem might be?

  11. Great to hear that, I hope, I am not pushing things too much ๐Ÿ˜‰
    The other issue: I am not verygood with php coding, but I hardly wanted to display images with normal size (intermediate) with psnGalleery2. I changed in psngallery2.php every switch-line with “thumb” to “picture” or “normal”, so normal size was default. Everything worked out perfected, until I tried to integrate my CPG album no. 5 (located http://www.pixal.de/cpg/thumbnails.php?album=5) via psnGallery2 into my blog – instead of any pictures, there was a text link to the the gallery looking for the pictures with an “normal_” prefix. CPG deleted the prefix after I was running the CPG function from the admin panel I described above, but psnGalery2 didn’t mange to get the “new” filename and so posted the “old” filename (with “normal_” prefix).

    Don’t bother too much about this. There is a veeeeery large possibility, that I screwed up by changing your code. I will patiently wait ’till you release V1.3.0 and then I will try this again. I think, you have done a really great job! Thanks again!

  12. I am working on the version 1.3.0 of the psnGallery2.
    The size issue is already solved in the alpha release.
    For your other issue, do you have further info ? What’s the behaviour ?

  13. Hi, and welcome back…
    Still have two issues: First, will there be an update for the size-problem? I didn’t manage to solve this by my own… Second, with CPG you can delete your fullsize-pictures with an function located in the admin-panel; the fullsize pictures are deleted and the intermediate pictures (named normal_) are re-named. Your psnGallery2 has some problmes with that.

    Glad, if you could help,

  14. Thank you for the system. I added a copperminepath tuple and changed the ecards… in the image links. Reason being is that my webroot is empty except for directories. I tried adding and setting ecards… in the config table, however it keeps getting overwritten somewhere.

    In the end, some nice work. Thank you very much for your efforts.



  15. Pingback: Tonos de Gris
  16. Hi,

    First, let me say thank you for the plugin, I have found it very useful.

    Second, I added one function to it. I need the functionality, so here it is, in case you wanted to include it in the plugin. A function to display an album based on a picture id instead of a album id.

    The code:

    function CPGAlbumFromPic ($pid, $nCols=4, $nSize=1, beforeCol=”

  17. “, $afterCol=”
  18. “, $beforeRow=”

      “, $afterRow=”

    “) {
    global $CONFIG,$cpgdb;

    $result = $cpgdb->query(“SELECT aid from {$CONFIG[‘TABLE_PICTURES’]} WHERE pid=’$pid'”);
    $rows = $cpgdb->get_results();
    CPGAlbum ($rows[0]->aid, $nCols, $nSize, $beforeCol, $afterCol, $beforeRow, $afterRow);

    Again, thanks.

  19. In the function psnGetPicURL is a bug: the switch statement for ‘fullSize’ will never work, because you do a ‘strtolower’ before the switch statement. ‘fullSize’ should be ‘fullsize’. All lowercase.

  20. Suuush, I forgot: I am trying to insert intermediate pictures (not thumbs) with , but changing of size (..|1) doesn’t seem to be effective…

  21. Salut Pascal,

    thank you for your great work. Finally, the …/displayimage.php problem seemed to be solved, links are working fine now.

    Still, I am trying to use my wp-installation with coppermine installed on a different server (I mentioned it right here: http://blog.idahocline.info/index.php?p=104#comments), but I am still getting this error message: Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.

    Could you please help?

    Nevertheless: keep up the good work, thank you!

    Greetings, Markus

Comments are closed.